Skip to main content Skip to navigation
Washington State University
Information Technology Services

Workstation Requirements

Operating SystemRequirement
WindowsSystem RequirementsPentium class processor or greater
100 MB hard disk space
Microsoft Installer, version 3.1
Windows 7, 8, 8.1, and Windows 10 x86 (32-bit) or x64 (64-bit)
Internet Explorer 6.0 is no longer supported
Cisco will not offer Windows XP and Vista as a supported operating system for present or future AnyConnect releases.
AnyConnect is not supported on Windows RT. There are no APIs provided in the operating system to implement this functionality. Cisco has an open request with Microsoft on this topic.
Mac OSOS RequirementsMac OS X 10.8, 10.9, 10.10 and 10.11
Max OS X Support Notes
Mac OS X 10.5, 10.6, and 10.7 are no longer supported by Cisco.
AnyConnect requires 50MB of hard disk space.

To operate correctly with Mac OS X, AnyConnect requires a minimum display resolution of 1024 by 640 pixels. Mac OS X 10.8 introduces a new feature called Gatekeeper that restricts which applications are allowed to run on the system. You can choose to permit applications downloaded from:
Mac App Store
Mac App Store and identified developers
Anywhere
The default setting is Mac App Store and identified developers (signed applications). AnyConnect release 4.1 is a signed application, but it is not signed using an Apple certificate. This means that you must either select the Anywhere setting or use Control-click to bypass the selected setting to install and run AnyConnect from a pre-deploy installation. Users who web deploy or who already have AnyConnect installed are not impacted. For further information see: http://www.apple.com/macosx/mountain-lion/security.html
LinuxOS Requirements
x86 instruction set.
64-bit processor.
32 MB RAM.
20 MB hard disk space.
Superuser privileges are required for installation.
libstdc++ users must have libstdc++.so.6(GLIBCXX_3.4) or higher, but below version 4.
Java 5 (1.5) or later. The only version that works for web installation is Sun Java. You must install Sun Java and configure your browser to use that instead of the default package.
zlib - to support SSL deflate compression
xterm - only required if you're doing initial deployment of AnyConnect via Web launch from ASA clientless portal.
gtk 2.0.0.
gdk 2.0.0
libpango 1.0 or a compatible build such as package pangox-compat-0.0.2-2.el7.x86_64.rpm or pangox-compat-0.0.2-3.fc20.x86_64.rpm
iptables 1.2.7a or later.
tun module supplied with kernel 2.4.21, 2.6
Web based installation of the sslvpn client utilizes either ActiveX (with IE) or Oracle Java to download and install the clients. Because of the numerous security issues that Java and ActiveX poses, it is highly recommended that users download the clients from the following web page and manually install them and not have to deal with Java or ActiveX. http://infotech.wsu.edu/NetworkService/VPN/VPN.aspx